phpmyforum

waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

Hallo Lighty, seit der Umstellung auf von PHP5.3 auf PHP5.5 gibt es Probleme mit den Umlauten im Forum. Betroffen ist das Beitrag editieren sowie die Shoutbox. In der Soutbox bleibt der Beitrag leer, beim Beitrag das Fenster fürs editieren. Was müßte ich ändern, damit ich es unter PHP5.5 betreiben kann.
Ich hoffe du kannst mir helfen, Danke!!!!
Benutzeravatar
Lighty
Beiträge: 8396
Registriert: 24.08.2006, 02:28

Beitrag von Lighty »

Hallo waaglein !

Kannst du ggf. noch mal zurück wechseln !?
Es sind dazu einige Änderungen an Template-Dateien erforderlich !
Liste kann ich dir hier rein stellen ! ;)

... Beitrag habe ich mal zu pmf rüber geschubst ! ;)
LG, Lighty
waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

Ja, momentan kann ich noch wechseln. Würde mich über deine Hilfe freuen. Version 4.1.17 :oops:
Benutzeravatar
Lighty
Beiträge: 8396
Registriert: 24.08.2006, 02:28

Beitrag von Lighty »

waaglein hat geschrieben:Version 4.1.17 :oops:
... ui ui ui - die Updates hast du manuell aber gemacht, oder !?
( weil aktuell ist V. 4.2.1 )

Falls nicht solltest du ggf. erst updaten !?
LG, Lighty
waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

Hm.. kann ich nicht genau mehr sagen, würde von der 4.1.17 ausgehen. Habe wohl aufgrund vorhandener "Hacks" die Version auf 4.1.17 gelassen. Kann man die 4.1.17 PHP5.5 fähig machen? :)
Benutzeravatar
Lighty
Beiträge: 8396
Registriert: 24.08.2006, 02:28

Beitrag von Lighty »

... denke schon - ich schau mal ! ;)
LG, Lighty
AranankA
Beiträge: 1558
Registriert: 11.09.2006, 10:12

Beitrag von AranankA »

Frage: Warum diese vollkommen veraltete (seit 2005 statisch bis auf kleinere Securupdates) und faktisch und praktisch kaum mehr supportete Forensoftware (die "aktuelle" Version ist 5 Jahre alt und die Programmierer haben ihre Internetpräsenz aufgegeben!)?

Wir haben inzwischen PHP7.x und PDO Datenbankanbindung (max. noch per mysqli; da aber auch schon deprecated), die Provider arbeiten an der konsequenten Einbindung dieser Version und deaktivieren Ältere.
Da bietet es sich doch an, auf unterstützende Forensysteme umzusteigen (z.B. myBB 1.8 + oder phpBB 3.2+).

Will sagen: Wenn schon die Umstellung auf PHP 5.5 so stelzt, wird es mit einer weiteren Steigerung in der PHP Version doch noch Flickwerkiger. Das kann doch nicht im Sinne des Admins liegen?
Benutzeravatar
Lighty
Beiträge: 8396
Registriert: 24.08.2006, 02:28

Beitrag von Lighty »

Hallo AranankA !

Ich sags mal so - never change a running system ! ;)
Die Konvertierung zu einem anderen System ist zudem weit aufwändiger als die Anpassungen für PHP 5.5 / 5.6 !
Ich habe mir in letzter Zeit so einige Forensysteme angeschaut,
aber "keines" ist administrativ so übersichtlich und leicht zu händeln wie das phpmyforum !
Irgend wann wird wohl leider ein Wechsel fällig werden, aber das muss erstmal getestet werden und zu 100% funktionieren !
LG, Lighty
AranankA
Beiträge: 1558
Registriert: 11.09.2006, 10:12

Beitrag von AranankA »

Ich verstehe, was du damit meinst. Trotzdem finde ich es nicht empfehlenswert, weiterhin auf veralteten Angeboten zu beharren! Schließlich ist das ja letztendlich auch eine Frage der Sicherheit und des Sitehandlings.

Schau mal hier rein und gib die Adresse vom Forum ein! Dann wirst du sehen, was ich meine...

Ich zitiere mal die Webkrauts (hier nachzulesen):
Die kurzfristige Lösung von heute ist der Müll von morgen
Benutzeravatar
Lighty
Beiträge: 8396
Registriert: 24.08.2006, 02:28

Beitrag von Lighty »

Hallo waaglein !

Ich habe mal gestöbert und tatsächlich noch alles gefunden ! ;)

Anleitung und Dateien findest du hier !
http://www.lightys-pchilfe-forum.info/topic.php?id=8492

Bei Problemen - melden - aber das weißt du ja, ne !? ;)
LG, Lighty
waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

Lighty hat geschrieben:Orginalbeitrag Lesen

Hallo waaglein !

Ich habe mal gestöbert und tatsächlich noch alles gefunden ! ;)

Anleitung und Dateien findest du hier !
http://www.lightys-pchilfe-forum.info/topic.php?id=8492

Bei Problemen - melden - aber das weißt du ja, ne !? ;)
Hallo, herzlichen Dank für deine Mühe. da fällt mir so richtig ein Stein vom Herzen.
waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

AranankA hat geschrieben:Orginalbeitrag Lesen

Frage: Warum diese vollkommen veraltete (seit 2005 statisch bis auf kleinere Securupdates) und faktisch und praktisch kaum mehr supportete Forensoftware (die "aktuelle" Version ist 5 Jahre alt und die Programmierer haben ihre Internetpräsenz aufgegeben!)?
Hallo Arananka, Lighty hat`s ziemlich gut erklärt.

Ich vergleichs mal zusätzlich mit nem Auto.... Es gibt schöne moderne neue Autos mit viel moderner Technik, trotzdem lieben manche ihre Oldtimer.
Und ich liebe einfach diese Forensoftware so wie andere ihren Oldtimer.
Deswegen bin ich froh von Lighty Hilfe zu bekommen, da er warscheinlich der Jenige ist, der sich noch am Besten damit auskennt.
Herzlichen Dank an Ligthy!!!
waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

Aus Zeitgründen kann ich leider nur am Wochenende daran arbeiten. Ich habe heute die letzten Dateinen offline geändert um sie demnächst hochzuladen.
Habe noch folgende Fragen dazu:
1.) Ist egal an welcher Stelle ich bei der config.inc.cfg den Eintrag mache?
2.)Sind ja einige "Hacks" verbaut worden. Unter anderen die Shoutbox und das Portal. Ist bekannt was an der Shoutbox und am Portal für Anpassungen gemacht werden müssen?

Dankeschön.
Benutzeravatar
Lighty
Beiträge: 8396
Registriert: 24.08.2006, 02:28

Beitrag von Lighty »

waaglein hat geschrieben:Aus Zeitgründen kann ich leider nur am Wochenende daran arbeiten. Ich habe heute die letzten Dateinen offline geändert um sie demnächst hochzuladen.
... wenns nicht die Zeit ist, ist es die Lust - kenne ich ! ;)
1.) Ist egal an welcher Stelle ich bei der config.inc.cfg den Eintrag mache?
Nein, das define sollte zwischen if und //database eingebaut werden !
2.)Sind ja einige "Hacks" verbaut worden. Unter anderen die Shoutbox und das Portal. Ist bekannt was an der Shoutbox und am Portal für Anpassungen gemacht werden müssen?
Aktuell nicht bekannt - sollte man aber wohl raus bekommen könnnen !? ;)
Welche Hacks ( Versionen ) sind es denn genau !?
LG, Lighty
waaglein
Beiträge: 23
Registriert: 06.08.2007, 22:55

Beitrag von waaglein »

Hallo Lighty, habe heute die geänderten Dateien hochgeladen.

Umlaute in der Shoutbox funktioneren noch nicht. Es sollte sich um diese hier handeln. (Gleiche oder ähnliche Version).

http://your-pmf.bughunter2k.de/file_arc ... bbssd2ltl6

Hast du eine Idee?

Antworten

Zurück zu „phpmyforum“